Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 22, 2022 - 23:00 UTC
Scheduled
On Tuesday at 3:00PM PT, 11:00PM UTC, the Scale web application will enter into an expected 30 minute maintenance window to update our database infrastructure.
During this maintenance window, the following will not work: User Authentication to log in to Scale services Scale Rapid Scale Nucleus Scale Enterprise Web Application / Dashboard for Reviewing and Auditing Tasks The Task Submission and Retrieval API
Callbacks will be queued and sent after the maintenance window has been closed.
Posted Feb 18, 2022 - 18:11 UTC
This scheduled maintenance affected: API, Platform, Web Application, Quality Assurance, Document AI, and Nucleus.